FICHE CVE

CVE-2020-11079

Publiée le 2020-05-28 · Dernière modification le 2026-06-17

🇫🇷 EN BREF

Les applications utilisant le module npm `dns-sync` (versions 0.2.0 et antérieures) sont vulnérables à l'exécution de commandes à distance. Un attaquant peut exécuter des commandes arbitraires sur votre serveur si votre application transmet des entrées utilisateur non fiables directement aux méthodes vulnérables de la bibliothèque. Cette faille peut être exploitée via le réseau sans nécessiter d'authentification ni d'interaction de la part d'un utilisateur légitime.

CVSS 3.18.6 ÉLEVÉE
Publiée2020-05-28
Dernière modification2026-06-17

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisAucun
Interaction utilisateurAucune
PortéeModifiée
Impact sur la confidentialitéAucun
Impact sur l'intégritéÉlevé
Impact sur la disponibilitéAucun

RÉFÉRENCES

Description officielle du NVD (en anglais)

node-dns-sync (npm module dns-sync) through 0.2.0 allows execution of arbitrary commands . This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. This has been fixed in 0.2.1.