FICHE CVE

CVE-2020-5256

Publiée le 2020-03-09 · Dernière modification le 2026-06-17

🇫🇷 EN BREF

Les installations de BookStack antérieures à la version 0.25.5 sont vulnérables à l'exécution de code à distance via la fonctionnalité de téléchargement d'images. Un utilisateur authentifié peut téléverser un fichier PHP malveillant pour prendre le contrôle du serveur avec les permissions du processus web. Cette attaque est relativement difficile à exécuter, car elle nécessite un compte utilisateur valide et une interaction spécifique de l'utilisateur pour déclencher le script téléversé.

CVSS 3.17.9 ÉLEVÉE
Publiée2020-03-09
Dernière modification2026-06-17

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueÉlevée
Privilèges requisFaibles
Interaction utilisateurRequise
PortéeModifiée
Impact sur la confidentialitéÉlevé
Impact sur l'intégritéÉlevé
Impact sur la disponibilitéFaible

RÉFÉRENCES

Description officielle du NVD (en anglais)

BookStack before version 0.25.5 has a vulnerability where a user could upload PHP files through image upload functions, which would allow them to execute code on the host system remotely. They would then have the permissions of the PHP process. This most impacts scenarios where non-trusted users are given permission to upload images in any area of the application. The issue was addressed in a series of patches in versions 0.25.3, 0.25.4 and 0.25.5. Users should upgrade to at least v0.25.5 to avoid this vulnerability.