FICHE CVE

CVE-2022-31157

Publiée le 2022-07-15 · Dernière modification le 2026-06-17

🇫🇷 EN BREF

Les applications PHP utilisant la bibliothèque LTI 1.3 Tool Library (versions antérieures à 5.0) sont affectées par une faille dans la manière dont les jetons de sécurité aléatoires (nonces) sont générés. Un attaquant distant non authentifié peut exploiter ce manque de complexité pour prédire ces jetons et effectuer des actions non autorisées ou falsifier des requêtes. Cette attaque est relativement facile à exécuter car elle ne nécessite aucune interaction de l'utilisateur ni de privilèges particuliers, au-delà d'un accès réseau au serveur.

CVSS 3.17.5 ÉLEVÉE
Publiée2022-07-15
Dernière modification2026-06-17

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisAucun
Interaction utilisateurAucune
PortéeInchangée
Impact sur la confidentialitéAucun
Impact sur l'intégritéÉlevé
Impact sur la disponibilitéAucun

RÉFÉRENCES

Description officielle du NVD (en anglais)

LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.