FICHE CVE

CVE-2022-44645

Publiée le 2023-01-31 · Dernière modification le 2026-06-17

🇫🇷 EN BREF

Apache Linkis (version 1.3.0 et antérieures) présente une vulnérabilité lorsqu'il est connecté à une base de données MySQL via le pilote Connector/J. Un attaquant disposant d'un accès authentifié de bas niveau à la base de données peut exécuter du code arbitraire sur le serveur en configurant une nouvelle source de données avec des paramètres malveillants. Cette attaque peut être effectuée à distance et ne nécessite aucune interaction de la part d'un utilisateur légitime.

CVSS 3.18.8 ÉLEVÉE
Publiée2023-01-31
Dernière modification2026-06-17

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisFaibles
Interaction utilisateurAucune
PortéeInchangée
Impact sur la confidentialitéÉlevé
Impact sur l'intégritéÉlevé
Impact sur la disponibilitéÉlevé

RÉFÉRENCES

Description officielle du NVD (en anglais)

In Apache Linkis <=1.3.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures new datasource with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users to upgrade the version of Linkis to version 1.3.1.