CVE-2023-41835
Publiée le 2023-12-05 · Dernière modification le 2026-06-17
Les serveurs Apache Struts sont affectés par une faille qui ne permet pas le nettoyage des fichiers temporaires lorsqu'une requête de téléchargement multipart dépasse la longueur maximale autorisée pour une chaîne de caractères. Un attaquant distant non authentifié peut exploiter cette vulnérabilité en envoyant des requêtes spécifiquement conçues pour saturer l'espace disque du serveur, entraînant ainsi un déni de service. Cette attaque est facile à exécuter car elle ne nécessite aucun privilège spécial ni interaction de l'utilisateur, au-delà d'un accès réseau basique à l'application.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
When a Multipart request is performed but some of the fields exceed the maxStringLength limit, the upload files will remain in struts.multipart.saveDir even if the request has been denied. Users are recommended to upgrade to versions Struts 2.5.32 or 6.1.2.2 or Struts 6.3.0.1 or greater, which fixe this issue.