CVE-2023-50386
Publiée le 2024-02-09 · Dernière modification le 2026-06-17
Les installations d'Apache Solr (versions 6.0.0–8.11.2 et 9.0.0–9.4.0) sont affectées par une faille qui permet aux utilisateurs de télécharger des fichiers Java malveillants via l'API ConfigSets. Si des sauvegardes sont enregistrées dans un répertoire utilisé dans le classpath de Solr, un attaquant peut exécuter du code arbitraire sur le serveur pour prendre le contrôle total du système. Cela nécessite un accès réseau et une authentification utilisateur de bas niveau, mais aucune autre interaction de l'utilisateur n'est nécessaire pour déclencher l'exploitation.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
Improper Control of Dynamically-Managed Code Resources, Unrestricted Upload of File with Dangerous Type, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Solr.This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1. In the affected versions, Solr ConfigSets accepted Java jar and class files to be uploaded through the ConfigSets API. When backing up Solr Collections, these configSet files would be saved to disk when using the LocalFileSystemRepository (the default for backups). If the backup was saved to a directory that Solr uses in its ClassPath/ClassLoaders, then the jar and class files would be available to use with any ConfigSet, trusted or untrusted. When Solr is run in a secure way (Authorization enabled), as is strongly suggested, this vulnerability is limited to extending the Backup permissions with the ability to add libraries. Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue. In these versions, the following protections have been added: * Users are no longer able to upload files to a configSet that could be executed via a Java ClassLoader. * The Backup API restricts saving backups to directories that are used in the ClassLoader.