CVE-2024-27135
Publiée le 2024-03-12 · Dernière modification le 2026-06-17
Les Workers de fonctions Apache Pulsar (ainsi que les Brokers avec les fonctions activées) sont affectés par une faille dans leur manière de valider les entrées. Un attaquant disposant d'un accès authentifié avec des privilèges limités au réseau peut exécuter du code Java arbitraire sur le système hôte, contournant ainsi les bacs à sable (sandboxes) prévus pour les fonctions. Bien que l'attaque soit complexe à exécuter, elle ne nécessite aucune interaction de la part d'autres utilisateurs.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.