FICHE CVE

CVE-2024-27919

Publiée le 2024-04-04 · Dernière modification le 2026-06-17

🇫🇷 EN BREF

Les versions 1.29.0 et 1.29.1 d'Envoy proxy sont vulnérables à une attaque par déni de service via le protocole HTTP/2. Un attaquant non authentifié disposant d'un accès réseau peut faire planter votre serveur en envoyant un flux de trames de données spécifiques qui épuisent la mémoire disponible du système. Comme cela ne nécessite aucun privilège particulier ni interaction de l'utilisateur, l'exécution de cette attaque est relativement simple.

CVSS 3.17.5 ÉLEVÉE
Type de faiblesse
Publiée2024-04-04
Dernière modification2026-06-17

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisAucun
Interaction utilisateurAucune
PortéeInchangée
Impact sur la confidentialitéAucun
Impact sur l'intégritéAucun
Impact sur la disponibilitéÉlevé

RÉFÉRENCES

Description officielle du NVD (en anglais)

Envoy is a cloud-native, open-source edge and service proxy. In versions 1.29.0 and 1.29.1, theEnvoy HTTP/2 protocol stack is vulnerable to the flood of CONTINUATION frames. Envoy's HTTP/2 codec does not reset a request when header map limits have been exceeded. This allows an attacker to send an sequence of CONTINUATION frames without the END_HEADERS bit set causing unlimited memory consumption. This can lead to denial of service through memory exhaustion. Users should upgrade to versions 1.29.2 to mitigate the effects of the CONTINUATION flood. Note that this vulnerability is a regression in Envoy version 1.29.0 and 1.29.1 only. As a workaround, downgrade to version 1.28.1 or earlier or disable HTTP/2 protocol for downstream connections.