FICHE CVE

CVE-2025-54883

Publiée le 2025-08-06 · Dernière modification le 2026-06-17

🇫🇷 EN BREF

Les projets web utilisant Vision UI (version 1.4.0 et versions antérieures) sont affectés par une faille dans la manière dont le système génère des nombres aléatoires sécurisés. Un attaquant peut exploiter cette faiblesse mathématique pour prédire des valeurs « aléatoires », ce qui pourrait lui permettre de contourner des contrôles de sécurité ou de détourner des sessions. Cette opération est facile à exécuter à distance et ne nécessite ni authentification ni interaction de la part de l'utilisateur.

CVSS 4.09.3 CRITIQUE
Type de faiblesse
Publiée2025-08-06
Dernière modification2026-06-17

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Prérequis d'attaqueAucun
Privilèges requisAucun
Interaction utilisateurAucune
Confidentialité (système vulnérable)Élevée
Intégrité (système vulnérable)Élevée
Disponibilité (système vulnérable)Aucune
Confidentialité (système subséquent)Faible
Intégrité (système subséquent)Faible
Disponibilité (système subséquent)Aucune

RÉFÉRENCES

Description officielle du NVD (en anglais)

Vision UI is a collection of enterprise-grade, dependency-free modules for modern web projects. In versions 1.4.0 and below, the getSecureRandomInt function in security-kit versions prior to 3.5.0 (packaged in Vision-ui <= 1.4.0) contains a critical cryptographic weakness. Due to a silent 32-bit integer overflow in its internal masking logic, the function fails to produce a uniform distribution of random numbers when the requested range between min and max is larger than 2³². The root cause is the use of a 32-bit bitwise left-shift operation (<<) to generate a bitmask for the rejection sampling algorithm. This causes the mask to be incorrect for any range requiring 32 or more bits of entropy. This issue is fixed in version 1.5.0.