CVE-2025-55754
Publiée le 2025-10-27 · Dernière modification le 2026-10-08
Les serveurs Apache Tomcat s'exécutant sur Windows sont vulnérables à l'injection de journaux via des URL spécialement conçues. Un attaquant distant non authentifié peut injecter des séquences d'échappement ANSI dans les journaux du serveur afin de manipuler la console ou le presse-papiers de l'administrateur, pouvant ainsi le tromper pour l'amener à exécuter des commandes malveillantes. Pour que l'attaque réussisse, l'administrateur doit surveiller activement la console et interagir avec la sortie manipulée.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.