CVE-2025-66171
Publiée le 2026-05-08 · Dernière modification le 2026-10-07
Les environnements CloudStack utilisant le plugin Backup (versions 4.21.0.0 et 4.22.0.0) sont affectés par une faille dans la manière dont l'accès à l'API est validé. Un attaquant disposant d'un compte utilisateur authentifié standard peut exploiter cette vulnérabilité via le réseau pour créer de nouvelles machines virtuelles à partir des sauvegardes de n'importe quel autre utilisateur, accédant potentiellement à leurs données privées. Aucune interaction particulière de l'utilisateur n'est requise, bien que l'attaquant doive déjà posséder des identifiants de connexion valides pour le système.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and have access to specific APIs can create new VMs using backups of any other user of the environment. Backup plugin users using CloudStack 4.21.0.0+ are recommended to upgrade to CloudStack version 4.22.0.1, which fixes this issue.