CVE-2025-66172
Publiée le 2026-05-08 · Dernière modification le 2026-10-07
Les environnements CloudStack utilisant le plugin Backup (versions 4.21.0.0 et 4.22.0.0) sont affectés par une faille dans la manière dont le système vérifie les permissions d'accès. Un attaquant disposant d'un compte utilisateur authentifié standard peut restaurer à distance les volumes de sauvegarde d'un autre utilisateur et les attacher à ses propres machines virtuelles pour voler ou modifier des données. Cette attaque est facile à exécuter via le réseau et ne nécessite que des identifiants d'utilisateur basiques, sans aucune interaction supplémentaire de la part de la victime.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and have access to specific APIs can restore a volume from any other user's backups and attach the volume to their own VMs. Backup plugin users using CloudStack 4.21.0.0+ are recommended to upgrade to CloudStack version 4.22.0.1, which fixes this issue.