FICHE CVE

CVE-2026-105315

Publiée le 2026-10-05 · Dernière modification le 2026-10-06

🇫🇷 EN BREF

Les applications web utilisant `django-haystack` (version 3.3.0 ou antérieure) avec le backend Elasticsearch sont concernées. Un attaquant distant disposant de privilèges de haut niveau peut exécuter du code arbitraire en manipulant l'argument `result_class`. Bien que l'exploit soit public et ne nécessite aucune interaction de l'utilisateur, l'obligation d'être authentifié en tant qu'administrateur rend son exploitation difficile sur la plupart des systèmes.

CVSS 4.02.0 FAIBLE
Publiée2026-10-05
Dernière modification2026-10-06

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Prérequis d'attaqueAucun
Privilèges requisÉlevés
Interaction utilisateurAucune
Confidentialité (système vulnérable)Faible
Intégrité (système vulnérable)Faible
Disponibilité (système vulnérable)Faible
Confidentialité (système subséquent)Aucune
Intégrité (système subséquent)Aucune
Disponibilité (système subséquent)Aucune
Maturité de l'exploitPreuve de concept

RÉFÉRENCES

Description officielle du NVD (en anglais)

A vulnerability has been found in django-haystack up to 3.3.0. Affected is the function _to_python of the file haystack/backends/elasticsearch_backend.py of the component more_like_this Template Tag Handler. Such manipulation of the argument result_class leads to improper neutralization of directives in dynamically evaluated code. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.4.0 is able to address this issue. The name of the patch is eb05f193c9771a68dcc8cfac6674a0d48a52ee9d. It is suggested to upgrade the affected component.