CVE-2026-23985
Publiée le 2026-07-30 · Dernière modification le 2026-10-23
Les versions 1.5.0 à 5.0.0 d'Apache Superset sont affectées par une faille dans la manière dont les instructions SQL sont analysées. Un utilisateur authentifié peut envoyer une chaîne de requête spécialement conçue au serveur qui consomme des ressources CPU excessives, ce qui peut potentiellement entraîner le gel ou le plantage de l'application. Cette attaque peut être exécutée via le réseau avec une faible complexité, bien qu'elle nécessite que l'attaquant dispose d'un compte valide.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
A Regular Expression Denial of Service (ReDoS) vulnerability exists in Apache Superset versions 1.5.0 through 5.0.0. The vulnerability is located in the sql_parse.py component, specifically within the SQL_REGEX used for parsing SQL statements in the sqlparse library integration. The affected regular expression contains overlapping disjunctions that share a common outer quantifier. An authenticated attacker can exploit this by sending a maliciously crafted input string (specifically a long sequence of backslashes or similar characters) to endpoints that process SQL queries This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue. Workarounds: ● WAF Rules: Implement Web Application Firewall (WAF) rules to detect and block requests containing excessively long sequences of backslashes or suspicious repeated patterns in the queries.extras.where parameter. ● Rate Limiting: Ensure strict rate limiting is applied to the /api/v1/chart/data endpoint to reduce the impact of potential attacks.