CVE-2026-24457
Publiée le 2026-03-05 · Dernière modification le 2026-08-05
Les courtiers OpenMQ (versions antérieures à 6.5.2 et 6.9.0) sont affectés par une faille d'analyse de configuration non sécurisée. Un attaquant distant non authentifié peut exploiter cette vulnérabilité via le réseau, sans aucune interaction de l'utilisateur, pour lire des fichiers arbitraires du système d'exploitation hôte et, dans certains cas, parvenir à une exécution de code à distance. Il s'agit d'une vulnérabilité à haut risque car elle ne nécessite aucun identifiant ni accès spécial pour être exploitée.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
An unsafe parsing of OpenMQ's configuration in OpenMQ versions <6.5.2 and <6.9.0, allows a remote attacker to read arbitrary files from a MQ Broker's server. A full exploitation could read unauthorized files of the OpenMQ’s host OS. In some scenarios RCE could be achieved. This is fixed in OpenMQ 6.5.2, 6.9.0, and in GlassFish 7.0.26, 7.1.1, and 8.0.2.