CVE-2026-32881
Publiée le 2026-03-20 · Dernière modification le 2026-06-17
Les serveurs web Gleam utilisant les versions d'ewe 0.6.0 à 3.0.4 sont vulnérables à l'usurpation d'en-têtes (header spoofing). Un attaquant distant non authentifié peut envoyer une requête segmentée (chunked request) spécialement conçue pour écraser les en-têtes de sécurité, lui permettant ainsi de contourner les limites de débit basées sur l'IP ou de falsifier des identifiants d'authentification. Cette action est relativement facile à exécuter car elle ne nécessite aucune interaction de l'utilisateur et seulement un accès réseau standard au serveur.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
ewe is a Gleam web server. ewe is a Gleam web server. Versions 0.6.0 through 3.0.4 are vulnerable to authentication bypass or spoofed proxy-trust headers. Chunked transfer encoding trailer handling merges declared trailer fields into req.headers after body parsing, but the denylist only blocks 9 header names. A malicious client can exploit this by declaring these headers in the Trailer field and appending them after the final chunk, causing request.set_header to overwrite legitimate values (e.g., those set by a reverse proxy). This enables attackers to forge authentication credentials, hijack sessions, bypass IP-based rate limiting, or spoof proxy-trust headers in any downstream middleware that reads headers after ewe.read_body is called. This issue has been fixed in version 3.0.5.