FICHE CVE

CVE-2026-33232

Publiée le 2026-05-19 · Dernière modification le 2026-07-24

🇫🇷 EN BREF

Les versions 0.4.2 à 0.6.51 d'AutoGPT sont vulnérables à une attaque par déni de service pouvant provoquer le plantage complet du backend de la plateforme. Un attaquant non authentifié disposant d'un accès réseau peut appeler répétitivement un point de terminaison spécifique afin de saturer l'espace disque du serveur avec des fichiers temporaires, entraînant à terme la panne de la base de données et d'autres services système. Comme cette action ne nécessite ni connexion ni interaction de l'utilisateur, elle est relativement facile à exécuter.

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisAucun
Interaction utilisateurAucune
PortéeInchangée
Impact sur la confidentialitéAucun
Impact sur l'intégritéAucun
Impact sur la disponibilitéÉlevé

RÉFÉRENCES

Description officielle du NVD (en anglais)

AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Versions 0.4.2 through 0.6.51 are vulnerable to an unauthenticated Denial of Service (DoS) through the server due to uncontrolled disk space consumption. The download_agent_file endpoint creates persistent temporary files for every request but fails to delete them after they are served. An unauthenticated attacker can repeatedly call this endpoint to exhaust the server's disk space, causing the database or other system services to fail due to "No space left on device" errors, rendering the entire AutoGPT Platform backend unavailable to all users. This issue has been patched in version 0.6.52.