FICHE CVE

CVE-2026-33808

Publiée le 2026-04-15 · Dernière modification le 2026-10-26

🇫🇷 EN BREF

Les serveurs utilisant `@fastify/express` (v4.0.4 ou version antérieure) avec des options spécifiques de normalisation du routeur sont susceptibles de présenter une faille de contournement d'authentification. Un attaquant distant non authentifié peut accéder à des routes protégées en manipulant le chemin de l'URL — par exemple en ajoutant des slashs ou des points-virgules en double — pour inciter le système à ignorer le middleware de sécurité. Cette action est facile à exécuter via un réseau et ne nécessite aucune interaction de la part de l'utilisateur.

CVSS 4.09.1 CRITIQUE
Type de faiblesse
Publiée2026-04-15
Dernière modification2026-10-26

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Prérequis d'attaquePrésent
Privilèges requisAucun
Interaction utilisateurAucune
Confidentialité (système vulnérable)Élevée
Intégrité (système vulnérable)Élevée
Disponibilité (système vulnérable)Aucune
Confidentialité (système subséquent)Aucune
Intégrité (système subséquent)Aucune
Disponibilité (système subséquent)Aucune

RÉFÉRENCES

Description officielle du NVD (en anglais)

Impact@fastify/express v4.0.4 and earlier fails to normalize URLs before passing them to Express middleware when Fastify router normalization options are enabled. This allows complete bypass of path-scoped authentication middleware via duplicate slashes when ignoreDuplicateSlashes is enabled, or via semicolon delimiters when useSemicolonDelimiter is enabled. In both cases, Fastify router normalizes the URL and matches the route, but @fastify/express passes the original un-normalized URL to Express middleware, which fails to match and is skipped. An unauthenticated attacker can access protected routes by manipulating the URL path. PatchesUpgrade to @fastify/express v4.0.5 or later.