CVE-2026-40008
Publiée le 2026-07-10 · Dernière modification le 2026-10-25
Apache IoTDB (versions 1.0.0 à 2.0.9) est affecté par une faille qui permet à un attaquant de forcer le serveur à charger et à exécuter des classes Java arbitraires. Un attaquant distant peut utiliser cette vulnérabilité pour prendre le contrôle total du système, notamment pour lire, modifier ou supprimer des données. Cette exploitation est facile à réaliser car elle ne nécessite ni authentification, ni interaction de l'utilisateur, et peut être déclenchée via le réseau.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache IoTDB. The pipe processor reads a fully qualified Java class name and instantiates it using Class.forName().newInstance() without any validation or allowlisting. This issue affects Apache IoTDB: from 1.0.0 before 2.0.10. Users are recommended to upgrade to version 2.0.10, which fixes the issue.