CVE-2026-41871
Publiée le 2026-09-09 · Dernière modification le 2026-09-10
Les serveurs Apache Nutch (versions 1.10 à 1.22) sont sensibles à une faille de réflexion non sécurisée dans l'API REST. Un attaquant distant non authentifié peut exploiter cette vulnérabilité pour exécuter du code arbitraire, lui octroyant potentiellement un contrôle total sur les données et les services du système. Comme elle ne nécessite aucune interaction de l'utilisateur ni de privilèges particuliers, l'attaque est simple à exécuter via un réseau.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
Missing Authorization, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server (Nutch REST API). This issue affects Apache Nutch: from 1.10 through 1.22. Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .