FICHE CVE

CVE-2026-42155

Publiée le 2026-05-15 · Dernière modification le 2026-10-26

🇫🇷 EN BREF

Les versions Magento Long Term Support (LTS) antérieures à la 20.18.0 sont affectées par la prévisibilité des identifiants de session dans les API XML-RPC et SOAP. Un attaquant non authentifié disposant d'un accès réseau peut utiliser la méthode du brute-force sur ces identifiants pour détourner des sessions API actives et prendre le contrôle non autorisé de la boutique. Cette attaque est relativement facile à exécuter car elle ne nécessite aucune interaction de l'utilisateur ni d'identifiants préalables.

CVSS 4.09.3 CRITIQUE
Type de faiblesse
Publiée2026-05-15
Dernière modification2026-10-26

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Prérequis d'attaqueAucun
Privilèges requisAucun
Interaction utilisateurAucune
Confidentialité (système vulnérable)Élevée
Intégrité (système vulnérable)Élevée
Disponibilité (système vulnérable)Faible
Confidentialité (système subséquent)Aucune
Intégrité (système subséquent)Aucune
Disponibilité (système subséquent)Aucune

RÉFÉRENCES

Description officielle du NVD (en anglais)

Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, the XML-RPC / SOAP API session ID is generated using an outdated, time-based construction rather than a Cryptographically Secure Pseudo-Random Number Generator (CSPRNG). All inputs to the MD5 hash are time-derived and non-secure. Because the resulting digest relies entirely on the timestamp and the PHP internal LCG state, the effective entropy is severely constrained. This violates the OWASP ASVS v4 requirement of ≥ 64 bits of entropy (V3.2.2) and NIST SP 800-63B standards. By narrowing the LCG window (via server state leaks or general predictability) and leveraging the lack of API rate-limiting, an attacker can generate a localized pool of candidate MD5 hashes and execute a high-speed online brute-force attack to hijack active API sessions. This vulnerability is fixed in 20.18.0.