CVE-2026-44029
Publiée le 2026-05-05 · Dernière modification le 2026-10-26
Les versions du gestionnaire de paquets Nix antérieures à la 2.34.7 sont vulnérables à une faille de traversée de répertoire lors de la décompression de fichiers provenant d'une URL. Un attaquant peut fournir une archive spécialement conçue lui permettant d'écrire des fichiers arbitraires en dehors du répertoire prévu sur votre système. Cela peut être déclenché à distance, sans authentification ni interaction de l'utilisateur, si votre système récupère et décompresse automatiquement du contenu non approuvé.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
An issue was discovered in Nix before 2.34.7. Writing to arbitrary files can occur via "nix-prefetch-url --unpack" or "nix store prefetch-file --unpack" directory traversal. The fixed versions are 2.34.7, 2.33.6, 2.32.8, 2.31.5, 2.30.5, 2.29.4, and 2.28.7 (introduced in 2.24.7);