FICHE CVE

CVE-2026-44174

Publiée le 2026-07-16 · Dernière modification le 2026-10-24

🇫🇷 EN BREF

Les installations de Kirby CMS antérieures aux versions 4.9.1 et 5.4.1 sont affectées par un manque de validation dans les requêtes de collection. Un attaquant disposant d'un compte avec des privilèges restreints peut exploiter cette faille pour divulguer des chemins de serveurs sensibles et des hachages de mots de passe, augmenter ses privilèges vers d'autres utilisateurs ou supprimer des quantités importantes de données. L'exécution est facile via un réseau et ne nécessite qu'une session authentifiée basique, sans aucune autre interaction de l'utilisateur.

CVSS 4.08.7 ÉLEVÉE
Type de faiblesse
Publiée2026-07-16
Dernière modification2026-10-24

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Prérequis d'attaqueAucun
Privilèges requisFaibles
Interaction utilisateurAucune
Confidentialité (système vulnérable)Élevée
Intégrité (système vulnérable)Élevée
Disponibilité (système vulnérable)Élevée
Confidentialité (système subséquent)Aucune
Intégrité (système subséquent)Aucune
Disponibilité (système subséquent)Aucune

RÉFÉRENCES

Description officielle du NVD (en anglais)

Kirby is an open-source content management system. Prior to 4.9.1 and 5.4.1, Kirby did not validate the model attributes that were used in its collection queries, allowing attackers to include arbitrary model methods in their queries. This includes methods with sensitive data such as password() (disclosing the password hash) or root() (disclosing the absolute filesystem path on the server) as well as methods that perform impactful actions such as loginPasswordless() (causing a privilege escalation to another user) or delete() (deleting all queried models in one go if the authenticated user has appropriate permissions). This issue has been fixed in versions 4.9.1 and 5.4.1.