FICHE CVE

CVE-2026-44177

Publiée le 2026-07-16 · Dernière modification le 2026-10-24

🇫🇷 EN BREF

Les versions 5.3.0 à 5.4.0 de Kirby CMS sont affectées par une faille de traversée de répertoire (path traversal) dans la manière dont les identifiants d'utilisateur sont traités. Un attaquant non authentifié disposant d'un accès réseau peut sonder la structure des répertoires de votre serveur ou tromper le système pour lui faire exécuter des fichiers PHP arbitraires (plus précisément ceux nommés `index.php`), comme des fichiers de plugins. Cette attaque est relativement facile à exécuter car elle ne nécessite aucune authentification préalable ni interaction de l'utilisateur.

CVSS 4.08.8 ÉLEVÉE
Publiée2026-07-16
Dernière modification2026-10-24

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Prérequis d'attaqueAucun
Privilèges requisAucun
Interaction utilisateurAucune
Confidentialité (système vulnérable)Élevée
Intégrité (système vulnérable)Faible
Disponibilité (système vulnérable)Aucune
Confidentialité (système subséquent)Aucune
Intégrité (système subséquent)Aucune
Disponibilité (système subséquent)Aucune

RÉFÉRENCES

Description officielle du NVD (en anglais)

Kirby is an open-source content management system. In versions 5.3.0 and above but prior to 5.4.1, Kirby did not correctly validate the provided user ID, resulting in a path traversal vulnerability. Version 5.3.0 introduced a performance improvement to the Users collection that loaded user objects lazily when first needed. Users were queried by their ID, which was then used to locate the corresponding account directory under site/accounts. This affected the authentication API (accessible to unauthenticated requests), the users API (accessible only to authenticated users), and any other place that uses $users->find() to look up an individual user by a request-provided email or ID. As a result, an attacker could trigger arbitrary PHP file inclusion of files named  index.php (for example, the main PHP files of plugins), the impact of which depends on the logic those files contain. It also allowed probing for the existence of arbitrary directories on the server, letting attackers fingerprint the server and site setup, including installed plugins and the content structure. This issue has been fixed in version 5.4.1.