FICHE CVE

CVE-2026-44223

Publiée le 2026-05-12 · Dernière modification le 2026-06-22

🇫🇷 EN BREF

Les serveurs d'inférence vLLM (versions 0.18.0 à 0.19.x) sont vulnérables à une attaque par déni de service qui provoque le plantage du cœur du moteur. Un utilisateur authentifié disposant d'un accès réseau peut déclencher ce plantage simplement en envoyant une seule requête contenant des paramètres classiques de pénalité d'échantillonnage. Il s'agit d'une attaque de faible complexité qui ne nécessite aucun clic sur un lien ni interaction avec une invite ; elle requiert seulement la capacité de soumettre une requête API.

CVSS 3.16.5 MOYENNE
Type de faiblesse
Publiée2026-05-12
Dernière modification2026-06-22

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisFaibles
Interaction utilisateurAucune
PortéeInchangée
Impact sur la confidentialitéAucun
Impact sur l'intégritéAucun
Impact sur la disponibilitéÉlevé

RÉFÉRENCES

Description officielle du NVD (en anglais)

vLLM is an inference and serving engine for large language models (LLMs). From 0.18.0 to before 0.20.0, the extract_hidden_states speculative decoding proposer in vLLM returns a tensor with an incorrect shape after the first decode step, causing a RuntimeError that crashes the EngineCore process. The crash is triggered when any request in the batch uses sampling penalty parameters (repetition_penalty, frequency_penalty, or presence_penalty). A single request with a penalty parameter (e.g., "repetition_penalty": 1.1) is sufficient to crash the server. This vulnerability is fixed in 0.20.0.