FICHE CVE

CVE-2026-45803

Publiée le 2026-05-15 · Dernière modification le 2026-06-17

🇫🇷 EN BREF

Les versions 1.6.0 à 2.91.0 de GitHub CLI sont concernées lors de la consultation des journaux (logs) de workflow Actions dans le terminal. Un attaquant capable d'influencer le contenu des journaux — par exemple via une Pull Request — peut injecter des séquences d'échappement de terminal permettant de manipuler le contenu de votre écran ou, selon votre émulateur de terminal, d'exécuter des commandes arbitraires. Cela nécessite que vous exécutiez manuellement la commande `gh run view` pour consulter un journal malveillant, ce qui en fait un problème à faible risque nécessitant une interaction de l'utilisateur.

CVSS 3.13.5 FAIBLE
Type de faiblesse
Publiée2026-05-15
Dernière modification2026-06-17

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisFaibles
Interaction utilisateurRequise
PortéeInchangée
Impact sur la confidentialitéAucun
Impact sur l'intégritéFaible
Impact sur la disponibilitéAucun

RÉFÉRENCES

Description officielle du NVD (en anglais)

`gh` is GitHub’s official command line tool. From 1.6.0 to before 2.92.0, a security vulnerability has been identified in GitHub CLI that could allow terminal escape sequence injection when users view GitHub Actions workflow logs using gh run view --log or gh run view --log-failed. The vulnerability stems from the way GitHub CLI handles raw Actions log output. The gh run view --log and gh run view --log-failed commands stream workflow log lines to stdout or the configured pager without sanitizing terminal control sequences. An attacker who can influence GitHub Actions log content, for example via a PR triggered workflow, can embed escape sequences that are replayed in the user's terminal when they inspect the run. Depending on the victim's terminal emulator, injected sequences could change the window title, manipulate on screen content, or in some terminal emulators (such as screen) potentially execute arbitrary commands. This vulnerability is fixed in 2.92.0.