CVE-2026-46718
Publiée le 2026-06-02 · Dernière modification le 2026-07-22
Les versions 1.5.0 à 1.41 d'Apache Calcite sont vulnérables à une faille de réflexion non sécurisée. Un attaquant distant non authentifié peut envoyer des requêtes réseau spécialement conçues pour déclencher l'exécution de classes de code arbitraires, lui permettant potentiellement de lire ou de modifier des données sensibles. Cette exploitation est relativement simple à réaliser car elle ne nécessite ni authentification préalable ni interaction de l'utilisateur.
DÉTAIL DU VECTEUR CVSS
RÉFÉRENCES
Description officielle du NVD (en anglais)
Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. This issue affects Apache Calcite: from 1.5.0 before 1.42. Users are recommended to upgrade to version 1.42, which fixes the issue.