FICHE CVE

CVE-2026-47323

Publiée le 2026-05-19 · Dernière modification le 2026-10-26

🇫🇷 EN BREF

Les systèmes utilisant Apache Camel avec des points de terminaison CXF-RS, CXF-SOAP ou Knative HTTP sont concernés. Un attaquant non authentifié peut envoyer des requêtes HTTP spécialement conçues pour injecter des en-têtes internes, ce qui pourrait lui permettre d'exécuter du code à distance ou d'écrire des fichiers arbitraires si le système transmet ces messages à des composants tels que `camel-exec` ou `camel-file`. Cette attaque est facile à réaliser car elle ne nécessite qu'un accès réseau basique, sans interaction d'utilisateur ni identifiants.

CVSS 3.19.8 CRITIQUE
Type de faiblesse
Publiée2026-05-19
Dernière modification2026-10-26

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisAucun
Interaction utilisateurAucune
PortéeInchangée
Impact sur la confidentialitéÉlevé
Impact sur l'intégritéÉlevé
Impact sur la disponibilitéÉlevé

RÉFÉRENCES

Description officielle du NVD (en anglais)

Camel-CXF and Camel-Knative Message Header Injection via Missing Inbound Filtering The CXF and Knative HeaderFilterStrategy implementations (CxfRsHeaderFilterStrategy in camel-cxf-rest, CxfHeaderFilterStrategy in camel-cxf-transport, and KnativeHttpHeaderFilterStrategy in camel-knative-http) only filter outbound Camel-internal headers via setOutFilterStartsWith, while not configuring inbound filtering via setInFilterStartsWith. As a result, an unauthenticated attacker can inject Camel-internal headers (e.g. CamelExecCommandExecutable, CamelFileName) via HTTP requests to CXF-RS or CXF-SOAP endpoints. When a route forwards messages from these endpoints to header-driven components such as camel-exec or camel-file, the injected headers override configured values, enabling remote code execution or arbitrary file writes. This is the same pattern that was previously addressed in camel-undertow (CVE-2025-30177), the broader incoming-header filter (CVE-2025-27636 and CVE-2025-29891), and non-HTTP strategies (CVE-2026-40453). This issue affects Apache Camel: from 3.18.0 before 4.14.6, from 4.15.0 before 4.18.2. Users are recommended to upgrade to version 4.19.0, which fixes the issue. If users are on the 4.18.x LTS releases stream, then they are suggested to upgrade to 4.18.2. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6.