FICHE CVE

CVE-2026-50169

Publiée le 2026-06-22 · Dernière modification le 2026-07-09

🇫🇷 EN BREF

Les applications web conçues avec les versions affectées du framework Angular sont vulnérables à un défaut de gestion des requêtes dans le service worker. Un attaquant pourrait potentiellement divulguer des cookies de session ou des données sensibles en incitant l'application à suivre des redirections HTTP que le développeur avait explicitement tenté de bloquer. Cette exploitation est difficile à réaliser, car elle nécessite que la victime interagisse avec un site ou un lien malveillant alors que l'application est active dans son navigateur.

CVSS 4.05.7 MOYENNE
Publiée2026-06-22
Dernière modification2026-07-09

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueLocal
Complexité d'attaqueÉlevée
Prérequis d'attaquePrésent
Privilèges requisAucun
Interaction utilisateurPassive
Confidentialité (système vulnérable)Élevée
Intégrité (système vulnérable)Aucune
Disponibilité (système vulnérable)Aucune
Confidentialité (système subséquent)Aucune
Intégrité (système subséquent)Aucune
Disponibilité (système subséquent)Aucune

RÉFÉRENCES

Description officielle du NVD (en anglais)

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips the strict, client-defined request redirect policy configuration (such as redirect: 'error'), falling back to the browser's default 'follow' strategy. If the target web application makes client-side requests with a strict policy (e.g., expecting a network error instead of automatically following redirects), the service worker will bypass this instruction and automatically follow HTTP 3xx redirects to other destinations. This acts as an unintended proxy/intermediary ("Confused Deputy") and can result in cookie/credential exposure or same-origin session-restricted data leakage if public dynamic routes redirect to sensitive routes. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.