FICHE CVE

CVE-2026-55559

Publiée le 2026-08-28 · Dernière modification le 2026-08-28

🇫🇷 EN BREF

Les frameworks de contrôle de mission Yamcs (versions antérieures à 5.12.8 et 5.13.2) sont sensibles à une faille d'injection de configuration. Un attaquant non authentifié disposant d'un accès réseau peut envoyer une requête API spécialement conçue pour injecter une entrée de service malveillante, lui permettant ainsi d'exécuter des commandes système arbitraires avec les privilèges du compte de service Yamcs. Cette exploitation est facile à réaliser et ne nécessite aucune interaction de l'utilisateur ni d'identifiants préalables.

CVSS 3.19.8 CRITIQUE
Publiée2026-08-28
Dernière modification2026-08-28

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisAucun
Interaction utilisateurAucune
PortéeInchangée
Impact sur la confidentialitéÉlevé
Impact sur l'intégritéÉlevé
Impact sur la disponibilitéÉlevé

RÉFÉRENCES

Description officielle du NVD (en anglais)

Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs inserts templateArgs from POST /api/instances and PATCH /api/instances/{instance} into YAML through VarStatement.append in yamcs-core/src/main/java/org/yamcs/templating/VarStatement.java without YAML-context escaping. The rendered configuration is parsed by YamcsServer.createInstance and loaded by YamcsServerInstance, allowing an attacker to inject a services entry for org.yamcs.ProcessRunner. Deployments without security.yaml expose the operation through the guest superuser, while secured deployments require SystemPrivilege.CreateInstances. Successful exploitation executes commands as the Yamcs service account. This issue is fixed in versions 5.12.8 and 5.13.2.