FICHE CVE

CVE-2026-55568

Publiée le 2026-06-23 · Dernière modification le 2026-06-26

🇫🇷 EN BREF

Les applications PHP utilisant le client HTTP Guzzle sont concernées si elles sont configurées pour utiliser un proxy HTTPS chiffré sur un système disposant d'une version obsolète de libcurl (antérieure à la 7.50.2). Un attaquant positionné sur le réseau entre le serveur et le proxy peut intercepter des données sensibles, notamment les identifiants d'authentification du proxy et la destination des requêtes tunnellisées, car le trafic est transmis en clair. Cela ne nécessite ni authentification ni interaction de l'utilisateur, bien que cela dépende de l'accès de l'attaquant au chemin réseau spécifique du trafic.

CVSS 3.15.9 MOYENNE
Publiée2026-06-23
Dernière modification2026-06-26

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueÉlevée
Privilèges requisAucun
Interaction utilisateurAucune
PortéeInchangée
Impact sur la confidentialitéÉlevé
Impact sur l'intégritéAucun
Impact sur la disponibilitéAucun

RÉFÉRENCES

Description officielle du NVD (en anglais)

Guzzle is an extensible PHP HTTP client. Prior to 7.12.1, in certain configurations, traffic expected to be protected by TLS on the hop to the proxy is transmitted in cleartext. Proxy authentication credentials (the Proxy-Authorization header, proxy userinfo in the proxy URL, or CURLOPT_PROXYUSERPWD) are sent without encryption, and the CONNECT target host and port for tunneled HTTPS requests are exposed. The built-in cURL handlers (GuzzleHttp\Handler\CurlHandler and GuzzleHttp\Handler\CurlMultiHandler, used by default whenever the PHP cURL extension is available) accept an https:// proxy. libcurl older than 7.50.2 silently treats an https:// proxy as a plaintext http:// proxy. The TLS connection to the proxy is never established, and the proxy leg is cleartext with no error or warning. An application is affected when it sends requests through one of the built-in cURL handlers, configures an https:// proxy expecting the proxy connection itself to be encrypted, and runs with libcurl older than 7.50.2. This vulnerability is fixed in 7.12.1.