FICHE CVE

CVE-2026-6270

Publiée le 2026-04-16 · Dernière modification le 2026-06-17

🇫🇷 EN BREF

Les applications Fastify utilisant `@fastify/middie` (version 9.3.1 et antérieures) peuvent ne pas appliquer les middlewares d'authentification aux routes des plugins enfants. Un attaquant peut contourner les contrôles de sécurité pour accéder à des données protégées ou effectuer des actions non autorisées en envoyant des requêtes directement vers ces portées enfants. Cette attaque est facile à exécuter car elle ne nécessite aucune authentification, aucune interaction de l'utilisateur et peut être réalisée à distance via le réseau.

CVSS 3.19.1 CRITIQUE
Type de faiblesse
Publiée2026-04-16
Dernière modification2026-06-17

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Privilèges requisAucun
Interaction utilisateurAucune
PortéeInchangée
Impact sur la confidentialitéÉlevé
Impact sur l'intégritéÉlevé
Impact sur la disponibilitéAucun

RÉFÉRENCES

Description officielle du NVD (en anglais)

@fastify/middie versions 9.3.1 and earlier do not register inherited middleware directly on child plugin engine instances. When a Fastify application registers authentication middleware in a parent scope and then registers child plugins with @fastify/middie, the child scope does not inherit the parent middleware. This allows unauthenticated requests to reach routes defined in child plugin scopes, bypassing authentication and authorization checks. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds.