FICHE CVE

CVE-2026-71438

Publiée le 2026-08-06 · Dernière modification le 2026-10-24

🇫🇷 EN BREF

Les applications utilisant Mermaid.js pour les diagrammes sont affectées si elles transmettent des entrées utilisateur non approuvées directement aux fonctions de configuration de la bibliothèque. Un attaquant pourrait exploiter cette pollution de prototype pour modifier le comportement de l'application, entraînant potentiellement un déni de service ou d'autres problèmes de stabilité. Cette attaque est difficile à réaliser, car elle nécessite un accès local, des privilèges de haut niveau et une implémentation spécifique et non standard du logiciel.

CVSS 4.02.4 FAIBLE
Publiée2026-08-06
Dernière modification2026-10-24

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueLocal
Complexité d'attaqueFaible
Prérequis d'attaquePrésent
Privilèges requisÉlevés
Interaction utilisateurActive
Confidentialité (système vulnérable)Aucune
Intégrité (système vulnérable)Faible
Disponibilité (système vulnérable)Faible
Confidentialité (système subséquent)Élevée
Intégrité (système subséquent)Élevée
Disponibilité (système subséquent)Élevée

RÉFÉRENCES

Description officielle du NVD (en anglais)

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid's configuration setters (mermaid.initialize, mermaidAPI.setConfig, and mermaidAPI.updateSiteConfig) merge caller-supplied configuration into Mermaid's internal config using the assignWithDepth deep-merge helper, which is vulnerable to prototype pollution. This is only exploitable if an application forwards untrusted data directly into one of these configuration entry points, which is outside their documented usage; diagram-supplied configuration (e.g. %%{init: {}}%% or YAML frontmatter) is not affected. This issue is fixed in versions 10.9.8 and 11.16.1.