FICHE CVE

CVE-2026-78654

Publiée le 2026-08-25 · Dernière modification le 2026-08-26

🇫🇷 EN BREF

Les applications utilisant le framework Cleverbrush ou la bibliothèque Deep (jusqu'à la version 4.4.0) sont vulnérables à une pollution de prototype via la fonction `deepExtend`. Un attaquant distant peut exploiter cette faille via le réseau, sans authentification ni interaction de l'utilisateur, pour modifier les attributs d'objets, ce qui peut potentiellement altérer le comportement de l'application. L'exploit étant public et la complexité de l'attaque faible, il est recommandé de passer à la version 4.4.1.

CVSS 4.05.5 MOYENNE
Publiée2026-08-25
Dernière modification2026-08-26

DÉTAIL DU VECTEUR CVSS

Vecteur d'attaqueRéseau
Complexité d'attaqueFaible
Prérequis d'attaqueAucun
Privilèges requisAucun
Interaction utilisateurAucune
Confidentialité (système vulnérable)Faible
Intégrité (système vulnérable)Faible
Disponibilité (système vulnérable)Faible
Confidentialité (système subséquent)Aucune
Intégrité (système subséquent)Aucune
Disponibilité (système subséquent)Aucune
Maturité de l'exploitPreuve de concept

RÉFÉRENCES

Description officielle du NVD (en anglais)

A vulnerability has been found in cleverbrush framework and deep up to 4.4.0. This impacts the function deepExtend of the file libs/deep/src/deepExtend.ts. The manipulation leads to improperly controlled modification of object prototype attributes. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. Upgrading to version 4.4.1 will fix this issue. The identifier of the patch is 810398c1308c500c3b8b6af380b5a89371389327. You should upgrade the affected component.